выгрузка данных 1С 7.7 в файл .xml - Форум
Суббота, 10.12.2016, 05:58
Wake Style
Главная страница | выгрузка данных 1С 7.7 в файл .xml - Форум | Регистрация | Вход
[ Новые сообщения · Участники · Правила форума · Поиск · RSS ]
Страница 1 из 11
Модератор форума: Бестия 
Форум » РАБОТА » Программирование 1С:Предприятие 7.7. » выгрузка данных 1С 7.7 в файл .xml (Помогите решить задачу выгрузки)
выгрузка данных 1С 7.7 в файл .xml
zhmenka78Дата: Понедельник, 17.02.2014, 13:40 | Сообщение # 1
Свежак
Группа: Пользователи
Сообщений: 1
Репутация: 0
Статус: Offline
по работе пришлось столкнуться с выгрузкой данных из 1С 7.7, а сам я не программист. Что-то посмотрел, почитал и написал код (пока не проверял на работоспособность) выбора остатком за период с помесячной разбивкой. Теперь надо, что бы данные выгружались в формате .xml, помогите с кодом!!!!

код выгрузки остатков:

Процедура Сформировать()
 Перем Запрос,ТекстЗапроса, Таб;
 //Создание объектатипа Запрос
 Запрос =СоздатьОбъект("Запрос");
 ТекстЗапроса =
 "//{{ЗАПРОС(Сформировать)
 |Период сВыбНачПериода по ВыбКонПериода;
 |Товар =Регистр.ОстаткиТоваров.Товар;
 |Склад =Регистр.ОстаткиТоваров.Склад;
 |ОстатокТовара =Регистр.ОстаткиТоваров.ОстатокТовара;
 |ЕдиницаПоУмолчанию =Регистр.ОстаткиТоваров.Товар.ЕдиницаПоУмолчанию;
 |ФункцияОстатокТовараКонОст = КонОст(ОстатокТовара);
 |Группировка Месяц;
 |Группировка Склад;
 |Группировка Товар;
 |"//}}ЗАПРОС
 ;
 // Если ошибка взапросе, то выход из процедуры
 ЕслиЗапрос.Выполнить(ТекстЗапроса) = 0 Тогда
  Возврат;
 КонецЕсли;
 // Подготовка кзаполнению выходных форм данными запроса
 Таб =СоздатьОбъект("Таблица");
 Таб.ИсходнаяТаблица("Сформировать");
 // Заполнение полей"Заголовок"
 Таб.ВывестиСекцию("Заголовок");
 Состояние("Заполнение выходнойтаблицы...");
 Таб.Опции(0, 0,Таб.ВысотаТаблицы(), 0);
 ПокаЗапрос.Группировка(1) = 1 Цикл
  // Заполнение полейМесяц
 Таб.ВывестиСекцию("Месяц");
  Пока Запрос.Группировка(2)= 1 Цикл
   // Заполнение полейСклад
  Таб.ВывестиСекцию("Склад");
   ПокаЗапрос.Группировка(3) = 1 Цикл
    // Заполнение полейТовар
   Таб.ВывестиСекцию("Товар");
   КонецЦикла;
  КонецЦикла;
 КонецЦикла;
 // Заполнение полей"Итого"
 Таб.ВывестиСекцию("Итого");
 // Вывод заполненнойформы
 Таб.ТолькоПросмотр(1);
 Таб.Показать("Сформировать","");
КонецПроцедуры
ВыбНачПериода = ДобавитьМесяц(ТекущаяДата(), -24, );
ВыбКонПериода = ТекущаяДата();

дальше есть идея начинать с

Процедура Выполнить()
Если
ЗагрузитьВнешнююКомпоненту (КаталогПРограммы () + "v7plus.dll") <>1
Тогда
Предупреждение ("Компонента не обнаружена");
Возврат;
КонецЕсли;
Анализатор = СоздатьОбъект ("AddIn.XMLParser");
Корень = Анализатор.СоздатьДокумент();
// дальше я запнулся ....!!!!!!!!!!!!
 
Форум » РАБОТА » Программирование 1С:Предприятие 7.7. » выгрузка данных 1С 7.7 в файл .xml (Помогите решить задачу выгрузки)
Страница 1 из 11
Поиск:


Меню сайта
Форма входа
Наш опрос
Зачем вы заходите на этот сайт?
Всего ответов: 0
Друзья сайта
Статистика
Copyright Wake Style © 2007
Используются технологии uCoz